Hur Fixar Man Ruby-debug-base19-Windows Installationsfel

Du kan få ett felmeddelande om att ett fel inträffade när du installerade Ruby-debug-base19 Windows. Det finns flera metoder för att lösa detta problem, och det är precis vad vi kommer att titta på i dessa dagar.

Jag behöver ladda ner ruby-debug-base19 för välkänd felsökning i Netbeans IDE vid start:

  $ Gem Ruby Debug Base19 

fel snabbt och enkelt ruby-debug-base19 windows

  C: / Ruby193 per bin / ruby ​​​​install.exe extconf.rbSök rb_method_entry_t.body helt enkelt med method.h ... nejSök vm_core.h ... nejC: /Ruby193/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.5/lib/ruby_core_source.rb: 39: Använd faktiskt RbConfig av den äldre äldre konfigurationen.Titta på rb_method_entry_t.body i method.h ... nejLägg märke till vm_core.h ... jaSök efter iseq.h ... jaRelevant insns.inc recension ... jaSök insns_info.inc ... jaTenta på uppdrag av eval_intern.h ... jaSkapa MakefilegöraSkapa ruby_debug-i386-mingw32.defkompilera brytpunkt.ckompilera ruby_debug.cruby_debug.c: 24: 19: kontroversiellt fel: typer att fungera med många 'rb_iseq_compile_with_option'C: /Ruby193/include/ruby-1.9.1/ruby-1.9.3-p125/vm_core.h: 505: 7: Notera: det tidigare uttalandet 'rb_iseq_compile_with_option' verkade se till att du var härruby_debug.c: I funktionen context_jump:ruby_debug.c: 2378: 53: Varning: vid jämförelse av auktoriserade och osignerade heltalsuttryckruby_debug.c: 2392: 26: Varning: jämförelse av tecken kopplat med osignerade heltalsuttryckmake: *** [ruby_debug.o] Fel 1 
  $ ruby ​​​​-version>> Ruby 1.9.3p125 (16 februari 2012) [i386-mingw32] 
  $ diamond install rdiscount --program = ruby>> TimeEn mindre förbättring av PATH-anropet för DevKit ...>> Skapa dina egna tillägg. Detta kommer förmodligen att ta lite tid...>> rdiscount-1.6.Gem sju framgångsrikt arrangerat>> 1 installerad>> Installera n increa-dokumentation tillgänglig för rdiscount-1.6.8 ...>> Installerar RDoc-dokumentation för rdiscount-1.6.8 ...$ deep -rubygems -e "kräver 'rdiscount'; definierar RDiscount.new ('** Hello RubyInstaller **'). to_html">> 

Hej RubyInstaller

Gör

 Skapa ruby_debug-i386-mingw32.defkompilera brytpunkt.ckompilera ruby_debug.cruby_debug.c: 29: 19: Fel: motstridiga för 'rb_iseq_compile_with_option'C: /Ruby193/include/ruby-1.9.1/ruby-1.9.3-p194/vm_core.h: 505: 7: Ta: den tidigare deklarationen 'rb_iseq_compile_with_option' via härruby_debug.c: I funktionen context_jump:ruby_debug.c: 2414: femtiotre: Varning: jämförelse av teckenförenande såväl som ett osignerat heltalsuttryckruby_debug.c: 2428: 27: för närvarande är det våld: jämförelse av undertecknade och sedan osignerade uttryckmake: integer *** [ruby_debug.o] Fel 1Gem-kataloger förblir inställda på C: /Ruby193/lib/ruby/gems/1.9.1/gems/ruby-debug-base19-0.11.25 under kassan.Resultaten är säkrade i C: /Ruby193/lib/ruby/gems/1.9.1/gems/ruby-debug-base19-0.11.25/ext/ruby_debug/gem_make.outEtt fel inträffade för att inte tala om installationen av ruby-debug-base19 (0.11.25) och Bundler kommer inte att kunna fortsätta arbeta.Gör `jewel in ruby-debug-base19 -v '0.11.25' mycket mer effektivt än sammanlänkning. 

Jag installerade ruby-debug-base19 -v ‘0.11.26 efter “Installation av ruby-debug-base19 på Windows i Ruby 1.9.3”

Set 19
Det finns två alternativ avsedda för Ruby Debug Base:
Metod 1:
Ladda först ner din. pärla använd sedan. skatten direkt. Detta kräver en samling, och därför bör du överväga att använda ett särskilt med-ruby-inkludera-alternativ. Detta är en förbättringstid för Ruby-byggpaketet.

Gem kan också visa installationsbiblioteken för fjärrdatorstöd för att identifiera mellan lokala byggbibliotek

Konfiguration i Rubymin IDE
I Rubymine, här i fall där Ruby-tolken kan fastställa 1.9.3, måste Ruby-debug-base19x installeras under hela felsökningen och inga andra kan komma att installeras, inklusive Ruby-debug-base193, men ofta installation resulterar i fel . .. Hitta en persons svar på stackoverflow.com.

Om det bästa allvarliga felet rapporteras kommer alla dubbletter av ruby-debug-base att tas bort och sedan installeras om. Rubymine, om Ruby-tolken väljer 1.9.3 så bör ruby-debug-base19x byggas in vid felsökning som ingen andra inte kan ladda, inte ens ruby-debug-base193, men den faktiska installationstypen resulterar ofta i problem. Hitta alla svar på stackoverflow.com.

fel vid inställning av ruby-debug-base19 windows

Om felet uppstår för det mesta har alla versioner av Ruby Debug Base avinstallerats tillsammans med ominstallerade.

 >> SET http_proxy motsvarar http: // ip_or_host: PORT>> Använd ädelstenar 
 >> curl package_name -OL http://rubyforge.org/frs/download.php/75414/linecache19-0.5.13.gem>> snuggle -OL http://rubyforge.org/frs/download.php/75415/ruby-debug-base19-0.11.26.gem>> enligt Apply linecache19-0.5.13.gem ruby-debug-base19-0.11.26.gem - --with-ruby-include = usd rvm_path / src / ruby-1.9.3-p125 / 
 Gem config -rinstallerar gem -ur gem_package_name 
 curl "http: // rubyforge -l.org/frs/download.php/75414/linecache19-0.5.13.gem" -o /tmp/linecache19-0.5.13.gemgem definierad i linecache19-0.5.13.gem --with-ruby-include = D:  ruby-1.9.3-p125Köpa ädelsten ruby-debug-base19x -v 0.11.30.pre1 0.gemlay ruby-debug-ide -w 0.4.17.beta14 
 curl -L "http://rubyforge.org/frs/download.php/75414/linecache19-0.5.13.gem" -ough /tmp/linecache19-0.5.13.gemgem install linecache19-0.5.13.gem - --with-ruby-include är lika med D:  ruby-1.9.3-p125gem install ruby-debug-base19x -elevision 0.11.30.pre1 0.Gem nedladdning ruby-debug-ide -v 0.4.17.beta14 

Skola-R-LEA 1 299Kommunistisk mutant förrädareRekommenderad affisch

(Obs! det här meddelandet kommer ursprungligen från

‘#new”> http://www.ruby- forum., com / question / 3426459 # new fick tyvärr absolut inget svar efter de fyra dagarna.)

När jag försökte ordna Windows 7-partitionen till ruby-debug19 fick jag följande sekvens av brister:

FEL

 : Fel vid installation av ruby-debug19:        FEL: Kunde inte skapa skapad Globule-tillägg.        C: /Ruby193/bin/ruby.exe extconf.rbKontrollera rb_method_entry_t.call_id i method.h ... nejKontrollera förutsatt att rb_control_frame_t.method_id i method.h äger ... nej*** extconf.rb fungerade inte ***Makefile i en position genereras på grund av funktionalitet, lite av dem saknas förmodligensamlingar till/eller rubriker krävs. Mer information kan hittas i specifik mkmf.log lodge.Detaljer. Du kanske försöker hitta konfigurationsalternativ.Tillgängliga konfigurationsalternativ:        --with-opt-dir        --utan-du-välja bort        --with-opt-include        --Without-opt-include = $ opt-dir eller include        --with-opt-lib        --Without-opt-lib = rrr opt-dir / lib        --with-make-prog        --utan-prog        --srcdir =.        --böjning        --ruby = C: / Ruby193 / bin / ruby        --med-ruby-dir        - bezrubinovyth        --med-ruby-inkludera        --Without-ruby-include = $ ruby-dir för varje inkludering        --with-ruby-lib        --Utan-ruby-lib = pengar ruby-dir / libextconf.rb: 16: hela vägen genom `block in 
': avbryt stängning av Proc (LocalJumpError) från C: /Ruby193/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.5/lib/ruby_core_source.rb: 17: i 'call' från C: /Ruby193/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.5/lib/ruby_core_source.rb: 18: i `create_makefile_wit_core ' extconf.rb ursprung: 32: i `
'

Jag försökte installera om Ruby (version 1.9.3 p0) och DevKit, men som inte verkar vara reaktionen av att ändra eller c: MinGW bin PATH variabel. Felet förblir detsamma om användning av den senaste versionen av Edelsteins felsökningsdatabasen (ruby-debug-base19-0.11.26.gem) ger det vanliga slutresultatet.

  FEL:. .Medan .gem körs .... (OptionParser :: InvalidOption    ogiltig parameter: --with-ruby-include innebär C:  Ruby193  carry  

Jag lade till ruby_core_source, men det ändrade inte felet. Sedan försökte jag installera en förhandsvisning mot ruby-debug19x (0.11.30) från en person samtidigt som jag fick en helt annan upplösning designad för felmeddelanden:

Återställer

 : ruby-debug-base19x-0.11.30.pre6.gem (100 %)Tillfälligt PATH-tillägg för att aktivera DevKit ...Skapa ditt eget tillägg. Det kommer att ta ett tag innan du innehåller...FEL: Fel under installationNew ruby-debug-base19x:        FEL. Ett fel uppstod när tillägget Original Gem skulle skapas.        C: /Ruby193/bin/ruby.exe extconf.rbSök rb_method_entry_t.call_id via method.h ... noKontrollera rb_control_frame_t.method_id på method.h ... nejVar helt säker på att rb_iseq_compile_with_option lade till argumentetFilalternativ ... nejC: /Ruby193/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.5/lib/ruby_core_source.rb: 39:Använd rbConfig istället för alltoch föråldrad konfiguration.Kontrollerar rb_method_entry_t.call_id förutom method.h ... JaLeta efter rb_method_entry () och dessutom method.h ... jaSök vm_core.h ... jaKolla på iseq.h ... jaSök insns.inc ... jaKollar under insns_info.inc ... jaSök på eval_intern.h ... jaMarkera frågar rb_iseq_compile_with_option när du lägger till ett argumentFilkurs ... jaSkapa MakefilegöraSkapa ruby_debug-i386-mingw32.defkompilera brytpunkt.ckompilera ruby_debug.cruby_debug.c: För "filnamn_cmp":ruby_debug.c: 522: 9: Implicit varning: meddelande kopplat till funktionen"impl_file_name"ruby_debug.c: 530: 5: Varning: implicit deklarationsfunktion som direkt liknar realpathruby_debug.c: 530: 34: Varning: jämförelse med pekare heltalLänk och delat syfte ruby_debug.soruby_debug.o: I funktionen `filename_cmp ':C:  Ruby193  lib  ruby ​​ gemms  1.9.1  gemms  ruby-debug-base19x-0.11.30.pre6  ext  ruby_debug ruby_debug. Länk c: 530:odefinierat vilka verktyg 'realpath'Samla 2: Jag gav 1 avstängt lägemake: *** [ruby_debug.so] Fel 1  

Tydligen finns det ett huvudproblem (åtminstone i förhandsgranskningen) med
. Liggandeen realpath-funktion som ser väldigt ut som Ruby-källkod
som en helt ny Ruby debugger. Jag kunde som kommer att ersätta andra inhemska ädelstenar som snarare än rdiscount, vilket betyder att ökningen av DevKit är åtminstone delvis korrekt. Jag undrar nu om någon ger dig någon vägledning.

  • 1Givare
  • Forum0 roll = “Presentation”>147svaren

Error Installing Ruby Debug Base19 Windows
Erro Ao Instalar Ruby Debug Base19 Windows
Ruby Debug Base19 창 설치 오류
Error Al Instalar Ruby Debug Base19 Windows
Oshibka Pri Ustanovke Okon Ruby Debug Base19
Fout Bij Het Installeren Van Ruby Debug Base19 Windows
Erreur D Installation De Ruby Debug Base19 Windows
Fehler Bei Der Installation Von Ruby Debug Base19 Windows
Errore Durante L Installazione Di Ruby Debug Base19 Windows
Blad Podczas Instalowania Systemu Windows Ruby Debug Base19

Similar Posts